Service degradation due to upgrade issues

Incident Report for Locust

Resolved

The servers have recovered and the system is operating normally. Thank you for your patience while we worked through the issue.
Posted Mar 08, 2026 - 11:30 EDT

Monitoring

We have implemented a fix and are currently monitoring the system. Performance is improving, but it may take some time for the servers to return to normal while the site continues to handle regular traffic.

Thank you for your patience while things stabilize.
Posted Mar 08, 2026 - 10:31 EDT

Identified

We are currently working through an issue affecting site performance due to a system upgrade. The site may be slow or partially unavailable while we address the problem.

We’ll post updates here as we make progress. Please try using Locust later on in the day.
Posted Mar 08, 2026 - 08:31 EDT
This incident affected: Locust App.